summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-11-06 12:24:00 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-11-06 13:54:58 +0200
commit2bf8146e311694ff8cdce9f0b1e638374682012a (patch)
tree5e7eb8458b4b7486f4230ab65558df397723cf00 /gnu/packages
parent56255c3e813b4b7d7f50306463d63be6fc9d720d (diff)
downloadguix-2bf8146e311694ff8cdce9f0b1e638374682012a.tar.gz
gnu: keepassxc: Only build documentation on supported systems.
* gnu/packages/password-utils.scm (keepassxc)[native-inputs]: Only add
ruby-asciidoctor on supported platforms.
[arguments]: Adjust configure-flags to skip documentation when
ruby-asciidoctor isn't supported.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/password-utils.scm16
1 files changed, 13 insertions, 3 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 24cceba055..c74ffe5242 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -157,8 +157,13 @@ human.")
       #:imported-modules `(,@%cmake-build-system-modules
                            (guix build qt-utils))
       #:configure-flags
-      #~(list "-DWITH_XC_ALL=YES"
-              "-DWITH_XC_UPDATECHECK=NO")
+      #~(append
+          (list "-DWITH_XC_ALL=YES"
+                "-DWITH_XC_UPDATECHECK=NO")
+          #$(if (member (%current-system)
+                        (package-transitive-supported-systems ruby-asciidoctor))
+              #~'()
+              #~(list "-DWITH_XC_DOCS=NO")))
       #:phases
       #~(modify-phases %standard-phases
           (replace 'check
@@ -172,7 +177,12 @@ human.")
             (lambda* (#:key inputs #:allow-other-keys)
               (wrap-qt-program "keepassxc" #:output #$output #:inputs inputs))))))
     (native-inputs
-     (list qttools-5 ruby-asciidoctor))
+     (append
+       (list qttools-5)
+       (if (member (%current-system)
+                   (package-transitive-supported-systems ruby-asciidoctor))
+         (list ruby-asciidoctor)
+         '())))
     (inputs
      (list argon2
            botan