summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-07-05 23:08:18 +0200
committerMarius Bakke <marius@gnu.org>2022-07-06 00:35:17 +0200
commit38aafcf958badfa6407ece2bb70c3b8dc70dba5e (patch)
tree81b875054aecf1cba7406a87225cb3d6e635c4d3 /gnu/packages
parent526071290f7329250adfdd6fa17de00ac84b1773 (diff)
downloadguix-38aafcf958badfa6407ece2bb70c3b8dc70dba5e.tar.gz
gnu: Boost: Python input is not native.
Even though it is not referenced, and not used when cross-compiling, the
architecture should match.

* gnu/packages/boost.scm (boost)[native-inputs]: Move PYTHON-MINIMAL-WRAPPER ...
[inputs]: ... here.
* gnu/packages/boost.scm (boost-for-mysql)[native-inputs, inputs]: Adjust
accordingly.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/boost.scm20
1 files changed, 11 insertions, 9 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index d6307d587a..e0589c1d7b 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -84,12 +84,14 @@
                (base32
                 "0fggarccddj6q4ifj3kn7g565rbhn4ia1vd45fxb7y57a6fmhpa7"))))
     (build-system gnu-build-system)
-    (inputs (list icu4c zlib))
+    (inputs
+     (append
+      (list icu4c zlib)
+      (if (%current-target-system)
+          '()
+          (list python-minimal-wrapper))))
     (native-inputs
-     (append (list perl tcsh)
-             (if (%current-target-system)
-                 '()
-                 (list python-minimal-wrapper))))
+     (list perl tcsh))
     (arguments
      (list
       #:imported-modules `((guix build python-build-system)
@@ -126,7 +128,7 @@
           (replace 'configure
             (lambda _
               (let ((icu #$(this-package-input "icu4c"))
-                    (python #+(this-package-native-input "python-minimal-wrapper")))
+                    (python #$(this-package-input "python-minimal-wrapper")))
                 (substitute* '("libs/config/configure"
                                "libs/spirit/classic/phoenix/test/runtest.sh"
                                "tools/build/src/engine/execunix.cpp")
@@ -177,7 +179,7 @@
                         (let* ((static? (member "link=static" make-flags))
                                (libext (if static? ".a" ".so"))
                                (python-version (python-version
-                                                #+(this-package-native-input
+                                                #$(this-package-input
                                                    "python-minimal-wrapper")))
                                (libboost_pythonNN
                                 (string-append "libboost_python"
@@ -345,8 +347,8 @@ across a broad spectrum of applications.")
             (delete 'provide-libboost_python)))
        ((#:make-flags make-flags)
         #~(cons* "--without-python" #$make-flags))))
-    (native-inputs
-     (modify-inputs (package-native-inputs boost)
+    (inputs
+     (modify-inputs (package-inputs boost)
        (delete "python-minimal-wrapper")))
     (properties '((hidden? . #t)))))