summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
author( <paren@disroot.org>2022-11-29 07:00:58 +0000
committerTobias Geerinckx-Rice <me@tobias.gr>2022-11-27 01:00:07 +0100
commit66d14a4da679969ebaef884d2c218176b899e650 (patch)
tree5c054401ac5992d36284e1bd531e357077a6bc5e /gnu/packages
parentf91afd93ffd560c13143ed6f08079a966e4ec24a (diff)
downloadguix-66d14a4da679969ebaef884d2c218176b899e650.tar.gz
gnu: rust-pathdiff-0.2: Update to 0.2.1.
* gnu/packages/crates-io.scm (rust-pathdiff-0.2): Update to 0.2.1.
[description]: Use full sentences.

Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 2744abfeab..3494634b55 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -39182,23 +39182,25 @@ path.Clean.")
 (define-public rust-pathdiff-0.2
   (package
     (name "rust-pathdiff")
-    (version "0.2.0")
+    (version "0.2.1")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "pathdiff" version))
-       (file-name
-        (string-append name "-" version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32
-         "0d2aqgrqhdn5kxlnd5dxv7d6pgsgf92r6r9gqm6bdh0mvsrk0xl7"))))
+        (base32 "1pa4dcmb7lwir4himg1mnl97a05b2z0svczg62l8940pbim12dc8"))))
     (build-system cargo-build-system)
-    (arguments `(#:skip-build? #t))
+    (arguments
+     (list #:skip-build? #t
+           #:cargo-inputs
+           `(("rust-camino" ,rust-camino-1))))
     (home-page "https://github.com/Manishearth/pathdiff")
     (synopsis "Library for diffing paths to obtain relative paths")
     (description
-     "Use diff_paths to construct a relative path from a provided base
-directory path to the provided path.")
+     "This package provides a Rust library for constructing a
+relative path from a provided base directory path to the provided
+path.")
     (license (list license:asl2.0 license:expat))))
 
 (define-public rust-pbkdf2-0.10