summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-04-26 18:25:35 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2023-05-02 00:52:01 -0400
commit854c57c3525325070e261a2e6f81d4016ef44bfa (patch)
tree71e3d8d6ef9b605deffc27a2033d8f1dddad5491 /gnu/packages
parent39ba8a10971f15264966823e8696d63c2995df86 (diff)
downloadguix-854c57c3525325070e261a2e6f81d4016ef44bfa.tar.gz
gnu: guitarix: Update to 0.44.1.
* gnu/packages/audio.scm (guitarix): Update to 0.44.1.
[arguments]: Use gexps.
[native-inputs]: Remove labels.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/audio.scm26
1 files changed, 13 insertions, 13 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 109133ba8e..9506378828 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -2316,7 +2316,7 @@ partial release of the General MIDI sound set.")
 (define-public guitarix
   (package
     (name "guitarix")
-    (version "0.43.1")
+    (version "0.44.1")
     (source (origin
              (method url-fetch)
              (uri (string-append
@@ -2324,14 +2324,14 @@ partial release of the General MIDI sound set.")
                    version ".tar.xz"))
              (sha256
               (base32
-               "1bsjlfd7x09p3iiljilyfbns6hpqn9cgp6psl4ccd6i1lwascfrm"))))
+               "063cdvrzrpnj08dm22z651hy5cz5bnsywf1z8b2kib2i9xskvs3p"))))
     (build-system waf-build-system)
     (arguments
-     `(#:tests? #f ; no "check" target
-       #:configure-flags
-       (list
-        ;; Add the output lib directory to the RUNPATH.
-        (string-append "--ldflags=-Wl,-rpath=" %output "/lib"))))
+     (list #:tests? #f ; no "check" target
+           #:configure-flags
+           #~(list
+              ;; Add the output lib directory to the RUNPATH.
+              (string-append "--ldflags=-Wl,-rpath=" #$output "/lib"))))
     (inputs
      (list libsndfile
            boost
@@ -2349,12 +2349,12 @@ partial release of the General MIDI sound set.")
            zita-resampler
            zita-convolver))
     (native-inputs
-     `(("gperf" ,gperf)
-       ("faust" ,faust)
-       ("intltool" ,intltool)
-       ("gettext" ,gettext-minimal)
-       ("pkg-config" ,pkg-config)
-       ("sassc" ,sassc)))
+     (list gperf
+           faust
+           intltool
+           gettext-minimal
+           pkg-config
+           sassc))
     (native-search-paths
      (list (search-path-specification
             (variable "LV2_PATH")