summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-08-20 14:48:40 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-08-20 18:33:50 +0200
commit96ca16857f2f407a18cb7e5671f84f07cdf5e06f (patch)
treecd69618abad302e0530e1f740caf9b9b5ca809eb /gnu/packages
parent04b909829c6f7f3cb8bed53ed0f6dbf4896cc771 (diff)
downloadguix-96ca16857f2f407a18cb7e5671f84f07cdf5e06f.tar.gz
gnu: ocaml-dose3: Fix reference to inputs and output.
The package 'lablgtk@2.8.10' (indirect dependency of ocaml-dose3)
fails to build so this patch could not be tested.

* gnu/packages/ocaml.scm
  (ocaml-dose3)[arguments]<#:make-flags>: Use #$output.
  (ocaml-dose3)[arguments]<#:configure-flags>: Don't use %build-inputs.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ocaml.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index c97f633cbe..0043e9fbee 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -44,6 +44,7 @@
   #:use-module (gnu packages algebra)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
+  #:use-module (gnu packages bash)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages compression)
@@ -644,13 +645,11 @@ underlying solvers like Cplex, Gurobi, Lpsolver, Glpk, CbC, SCIP or WBO.")
     (build-system ocaml-build-system)
     (arguments
      `(#:configure-flags
-       (list (string-append "SHELL="
-                            (assoc-ref %build-inputs "bash")
-                            "/bin/sh"))
+       ,#~(list (string-append "SHELL="
+                               #+(file-append (canonical-package bash-minimal)
+                                              "/bin/sh")))
        #:make-flags
-       (list (string-append "LIBDIR="
-                            (assoc-ref %outputs "out")
-                            "/lib/ocaml/site-lib"))
+       ,#~(list (string-append "LIBDIR=" #$output "/lib/ocaml/site-lib"))
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'fix-test-script