summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-02-12 14:41:11 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2021-02-12 14:41:11 +0100
commit9e549633827717d1bf6df1ef86580f88d3584b55 (patch)
tree3717d17ebee7f5de31085c89fad692e76d023240 /gnu/packages
parent512459f6f6540c89155a83d14372b195f2a23eca (diff)
downloadguix-9e549633827717d1bf6df1ef86580f88d3584b55.tar.gz
gnu: flrig: Use git repository.
The tarballs of older versions are not kept on the website.

* gnu/packages/radio.scm (flrig)[source]: Switch to git repository.
  [native-inputs]: Add autoconf and automake.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/radio.scm14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 3ac3d65e13..2b88db41c1 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -623,14 +623,18 @@ hardware.")
     (version "1.3.52")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "http://www.w1hkj.com/files/flrig/flrig-"
-                           version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://git.code.sf.net/p/fldigi/flrig")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "18c154080vl25cy4l5amh96abm6kzm7mzld9h58pabc28yqq8zl8"))))
+        (base32 "0vxn1wy5b2zfq20k93rfgq34m1nd3mxd74h8l98f90d85fhcqggy"))))
     (build-system gnu-build-system)
     (native-inputs
-     `(("pkg-config" ,pkg-config)))
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("pkg-config" ,pkg-config)))
     (inputs
      `(("fltk" ,fltk)
        ("libx11" ,libx11)