summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPierre-Henry Fröhring <phf@phf.net>2022-01-24 18:34:33 +0100
committerLudovic Courtès <ludo@gnu.org>2022-03-07 22:49:28 +0100
commitad464b1704d21ef59c91c1ab6935af4b34efd5c5 (patch)
treeab5c2e996cd3260adb86104aa5142fdf0377e041 /gnu/packages
parentc723aa98b556a734fd8b463c5510eeb73d851c64 (diff)
downloadguix-ad464b1704d21ef59c91c1ab6935af4b34efd5c5.tar.gz
gnu: Add python-multipart.
* gnu/packages/python-xyz.scm (python-multipart): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 38659e3209..2500ffa7ac 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29100,3 +29100,30 @@ manipulating stereolithography (STL) files.  It can convert STL files into
 POV-ray meshes, PDF and PostScript.  The Python modules allow for reading and
 writing STL files.  It supports both the text and binary forms of STL.")
     (license license:expat)))
+
+(define-public python-multipart
+  (package
+    (name "python-multipart")
+    (version "0.0.5")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "python-multipart" version))
+              (sha256
+               (base32
+                "0hzshd665rl1bkwvaj9va4j3gs8nmb478fbvligx20663xhmzfzp"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-six))
+    (native-inputs (list python-pyyaml python-mock python-pytest-cov))
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  ;; There is a bug in the test_suit specification.
+                  (add-after 'unpack 'patch-test-suite
+                    (lambda _
+                      (substitute* "setup.py"
+                        (("test_suite = 'multipart.tests.suite'")
+                         "test_suite = 'multipart.tests.test_multipart.suite'")))))))
+    (home-page "https://github.com/andrew-d/python-multipart")
+    (synopsis "Streaming multipart parser for Python")
+    (description
+     "This package provides a streaming multipart parser for Python.")
+    (license license:asl2.0)))