summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-02-22 19:47:19 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-02-22 20:14:15 +0100
commitc8f1781eb16d3275f01d274c656f63d76f746ec4 (patch)
tree476f38179f600fec1495b7def67a22cf2a4d9788 /gnu/packages
parent0172cd9c8ed38a1d05ee4030c99d4aa3a5f815d8 (diff)
downloadguix-c8f1781eb16d3275f01d274c656f63d76f746ec4.tar.gz
gnu: Add r-wordspace.
* gnu/packages/cran.scm (r-wordspace): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f6c32a6f24..ae8911f4c0 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -32294,6 +32294,35 @@ parsing.")
     ;; GPL 2 or GPL 3.
     (license license:gpl3)))
 
+(define-public r-wordspace
+  (package
+    (name "r-wordspace")
+    (version "0.2-7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "wordspace" version))
+       (sha256
+        (base32 "0hrjv5mag7gwl4wj7np248sdyns5i623wl37b11hlgalhbmlypyf"))))
+    (properties `((upstream-name . "wordspace")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-cluster r-iotools r-mass r-matrix r-rcpp r-sparsesvd))
+    (native-inputs (list r-knitr))
+    (home-page "https://wordspace.r-forge.r-project.org/")
+    (synopsis "Distributional semantic models in R")
+    (description
+     "The wordspace package turns R into an interactive laboratory for
+empirical research on @dfn{distributional semantic models} (DSM).  It consists
+of a small set of carefully designed functions, most of which
+
+@itemize
+@item encapsulate non-trivial R operations in a user-friendly manner or
+@item provide efficient and memory-lean C implementations of key operations.
+@end itemize
+")
+    (license license:gpl3)))
+
 (define-public r-mockery
   (package
     (name "r-mockery")