summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-02-16 18:38:27 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-04-05 15:02:30 +0300
commit877889f3ca45e2a7b6972e19e5f20be74cd3ef30 (patch)
tree0b4812b50c0196c3add530ce41c350cb82678f94 /gnu/packages
parentf71d1a08a1eade5dcc1df79d1b66a9524b113253 (diff)
downloadguix-877889f3ca45e2a7b6972e19e5f20be74cd3ef30.tar.gz
gnu: python-futures: Remove variable.
* gnu/packages/python.scm (python-futures): Remove it.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 150fce9540..c1813e38b4 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7257,9 +7257,9 @@ authenticated session objects providing things like keep-alive.")
 3.2.3 for use with older versions of Python and PyPy.")
     (license license:expat)))
 
-(define-public python-futures
+(define-public python2-futures
   (package
-    (name "python-futures")
+    (name "python2-futures")
     (version "3.0.3")
     (source
       (origin
@@ -7269,8 +7269,9 @@ authenticated session objects providing things like keep-alive.")
          (base32
           "1vcb34dqhzkhbq1957vdjszhhm5y3j9ba88dgwhqx2zynhmk9qig"))))
     (build-system python-build-system)
+    (arguments `(#:python ,python-2))
     (native-inputs
-     `(("python-setuptools" ,python-setuptools)))
+     `(("python2-setuptools" ,python2-setuptools)))
     (home-page "https://github.com/agronholm/pythonfutures")
     (synopsis
      "Backport of the concurrent.futures package from Python 3.2")
@@ -7280,9 +7281,6 @@ asynchronously executing callables.  This package backports the
 concurrent.futures package from Python 3.2")
     (license bsd-3)))
 
-(define-public python2-futures
-  (package-with-python2 python-futures))
-
 (define-public python-urllib3
   (package
     (name "python-urllib3")