summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-11-20 01:01:40 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-11-20 12:02:20 +0100
commitbcf7d0bc7babb244efb75d69313ea8f010f59bda (patch)
tree4284415cbc06201571631be949aa2601f6dd7d57 /gnu/packages
parent40d4b541d994c089ccee3c693dd0e994144031f2 (diff)
downloadguix-bcf7d0bc7babb244efb75d69313ea8f010f59bda.tar.gz
gnu: python-numba: Run tests conditionally.
* gnu/packages/python-xyz.scm (python-numba)[arguments]: Respect TESTS? argument.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5ba9b6d62b..43cee47e40 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22008,14 +22008,15 @@ validation testing and application logic.")
              (setenv "NUMBA_DISABLE_HSA" "1")
              (setenv "NUMBA_DISABLE_CUDA" "1")))
          (replace 'check
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (add-installed-pythonpath inputs outputs)
-             ;; Something is wrong with the PYTHONPATH when running the
-             ;; tests from the build directory, as it complains about not being
-             ;; able to import certain modules.
-             (with-directory-excursion "/tmp"
-               (setenv "HOME" (getcwd))
-               (invoke "python3" "-m" "numba.runtests" "-v" "-m")))))))
+           (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+             (when tests?
+               (add-installed-pythonpath inputs outputs)
+               ;; Something is wrong with the PYTHONPATH when running the
+               ;; tests from the build directory, as it complains about not being
+               ;; able to import certain modules.
+               (with-directory-excursion "/tmp"
+                 (setenv "HOME" (getcwd))
+                 (invoke "python3" "-m" "numba.runtests" "-v" "-m"))))))))
     (propagated-inputs
      `(("python-llvmlite" ,python-llvmlite)
        ("python-numpy" ,python-numpy)