summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-03-10 21:57:40 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-03-10 23:49:54 +0100
commitd08a4c776f1f55eb8cf4ad8e8a6ecbc4a74a7937 (patch)
treed4be15a931d7f4a681a19db53efbb6c058565e09 /gnu/packages
parentaab798976ad31912b6be7d07952d615bac3f0535 (diff)
downloadguix-d08a4c776f1f55eb8cf4ad8e8a6ecbc4a74a7937.tar.gz
gnu: Add rust-rustls-native-certs-0.5.
* gnu/packages/crates-io.scm (rust-rustls-native-certs-0.5): New variable.
(rust-rustls-native-certs-0.4): Inherit from above.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm36
1 files changed, 28 insertions, 8 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index d4f505c552..c32afd7464 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -34369,8 +34369,35 @@ rustc compiler.")
         ("rust-serde-derive" ,rust-serde-derive-1)
         ("rust-webpki-roots" ,rust-webpki-roots-0.14))))))
 
+(define-public rust-rustls-native-certs-0.5
+  (package
+    (name "rust-rustls-native-certs")
+    (version "0.5.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "rustls-native-certs" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "14i0bbbigk6r6262hvc51vz4dvqk1f3vg2f264wfvn2vi30vf1ss"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-openssl-probe" ,rust-openssl-probe-0.1)
+        ("rust-rustls" ,rust-rustls-0.19)
+        ("rust-schannel" ,rust-schannel-0.1)
+        ("rust-security-framework" ,rust-security-framework-2))))
+    (home-page "https://github.com/ctz/rustls-native-certs")
+    (synopsis "Use the platform native certificate store with rustls")
+    (description "@code{rustls-native-certs} allows rustls to use the platform
+native certificate store.")
+    (license
+     (list license:asl2.0 license:isc license:expat))))
+
 (define-public rust-rustls-native-certs-0.4
   (package
+    (inherit rust-rustls-native-certs-0.5)
     (name "rust-rustls-native-certs")
     (version "0.4.0")
     (source
@@ -34381,7 +34408,6 @@ rustc compiler.")
        (sha256
         (base32
          "1f2rkvdkz92qcmwryyqiw9phkqkf95g4962ljpfq5nkjfsd477b2"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
        (("rust-openssl-probe" ,rust-openssl-probe-0.1)
@@ -34393,13 +34419,7 @@ rustc compiler.")
        (("rust-ring" ,rust-ring-0.16)
         ("rust-untrusted" ,rust-untrusted-0.7)
         ("rust-webpki" ,rust-webpki-0.21)
-        ("rust-webpki-roots" ,rust-webpki-roots-0.20))))
-    (home-page "https://github.com/ctz/rustls-native-certs")
-    (synopsis "Use the platform native certificate store with rustls")
-    (description "@code{rustls-native-certs} allows rustls to use the platform
-native certificate store.")
-    (license
-     (list license:asl2.0 license:isc license:expat))))
+        ("rust-webpki-roots" ,rust-webpki-roots-0.20))))))
 
 (define-public rust-rusttype-0.9
   (package