summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAlexandr Vityazev <avityazev@posteo.org>2021-10-04 15:17:56 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-10-08 12:04:47 +0200
commitd3862d12bb1b69b395015caa480c1461ac6a575d (patch)
tree56734cbf5b4b87b8c98beee2486a7b360dc3186f /gnu/packages
parent2a7c57370c283755bb39a7ac12ef4639ef24211a (diff)
downloadguix-d3862d12bb1b69b395015caa480c1461ac6a575d.tar.gz
gnu: Add emacs-skempo.
* gnu/packages/emacs-xyz.scm (emacs-skempo): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8b86ba7040..db9e89a095 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3968,6 +3968,31 @@ strings.")
 Stack Overflow, Super User, and other StackExchange sites.")
       (license license:gpl3+))))
 
+(define-public emacs-skempo
+  (package
+    (name "emacs-skempo")
+    (version "0.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/xFA25E/skempo")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0na465f27p6n64sf0pj0aqdi384m1wy3hxcc2d6a67hs39rkyvi9"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-parent-mode" ,emacs-parent-mode)))
+    (home-page "https://github.com/xFA25E/skempo")
+    (synopsis "Enhancements for skeleton/tempo + abbrev")
+    (description
+     "Skempo is an attempt to improve Emacs built-in Skeleton and Tempo
+templates.  It tries to make a unified syntax for template definitions.  It
+also adds tags and marks support for Skeleton, and Abbrev support for Tempo.")
+    (license license:gpl3+)))
+
 (define-public emacs-toc-org
   (package
     (name "emacs-toc-org")