summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-03-08 18:57:57 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-03-12 14:45:53 +0100
commitff92c2873c0c8ab9fa6e90020d656aac47dfb088 (patch)
treee768420dae1b4593cbed54386ca2a9557c78edd2 /gnu/packages
parentd769b10714ba4ab96a27933b6840265cf6e06f37 (diff)
downloadguix-ff92c2873c0c8ab9fa6e90020d656aac47dfb088.tar.gz
gnu: r-annotationforge: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-annotationforge): Move from here...
* gnu/packages/bioconductor.scm (r-annotationforge): ...to here.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioconductor.scm32
-rw-r--r--gnu/packages/bioinformatics.scm32
2 files changed, 32 insertions, 32 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 0c36b01545..c698178067 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1487,6 +1487,38 @@ structure.")
 microarrays.")
     (license license:artistic2.0)))
 
+(define-public r-annotationforge
+  (package
+    (name "r-annotationforge")
+    (version "1.32.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "AnnotationForge" version))
+       (sha256
+        (base32
+         "0y3820dkvwz09wlmz9drx6gqpsr9cwppaiz40zafwfxbz65y8px7"))))
+    (properties
+     `((upstream-name . "AnnotationForge")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-annotationdbi" ,r-annotationdbi)
+       ("r-biobase" ,r-biobase)
+       ("r-biocgenerics" ,r-biocgenerics)
+       ("r-dbi" ,r-dbi)
+       ("r-rcurl" ,r-rcurl)
+       ("r-rsqlite" ,r-rsqlite)
+       ("r-s4vectors" ,r-s4vectors)
+       ("r-xml" ,r-xml)))
+    (native-inputs
+     `(("r-knitr" ,r-knitr)))
+    (home-page "https://bioconductor.org/packages/AnnotationForge")
+    (synopsis "Code for building annotation database packages")
+    (description
+     "This package provides code for generating Annotation packages and their
+databases.  Packages produced are intended to be used with AnnotationDbi.")
+    (license license:artistic2.0)))
+
 (define-public r-deseq2
   (package
     (name "r-deseq2")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 41372879fe..575158577c 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7387,38 +7387,6 @@ includes software to
 ")
       (license license:cc0))))
 
-(define-public r-annotationforge
-  (package
-    (name "r-annotationforge")
-    (version "1.32.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (bioconductor-uri "AnnotationForge" version))
-       (sha256
-        (base32
-         "0y3820dkvwz09wlmz9drx6gqpsr9cwppaiz40zafwfxbz65y8px7"))))
-    (properties
-     `((upstream-name . "AnnotationForge")))
-    (build-system r-build-system)
-    (propagated-inputs
-     `(("r-annotationdbi" ,r-annotationdbi)
-       ("r-biobase" ,r-biobase)
-       ("r-biocgenerics" ,r-biocgenerics)
-       ("r-dbi" ,r-dbi)
-       ("r-rcurl" ,r-rcurl)
-       ("r-rsqlite" ,r-rsqlite)
-       ("r-s4vectors" ,r-s4vectors)
-       ("r-xml" ,r-xml)))
-    (native-inputs
-     `(("r-knitr" ,r-knitr)))
-    (home-page "https://bioconductor.org/packages/AnnotationForge")
-    (synopsis "Code for building annotation database packages")
-    (description
-     "This package provides code for generating Annotation packages and their
-databases.  Packages produced are intended to be used with AnnotationDbi.")
-    (license license:artistic2.0)))
-
 (define-public r-rbgl
   (package
     (name "r-rbgl")