summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-05-27 11:34:44 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-05-27 11:37:53 +0300
commit1a847b708dfa13c5ea231c6fc729db0088079925 (patch)
tree09dd26f8c2643e23128bf16c8ea90fa69da55908 /gnu/packages
parentd1cd67af5dc305572b018e4dd46eb7d035244dda (diff)
downloadguix-1a847b708dfa13c5ea231c6fc729db0088079925.tar.gz
gnu: mpc123: Use 'modify-phases'.
* gnu/packages/mp3.scm (mpc123)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/mp3.scm28
1 files changed, 13 insertions, 15 deletions
diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
index e3133d788a..f5789487b5 100644
--- a/gnu/packages/mp3.scm
+++ b/gnu/packages/mp3.scm
@@ -428,22 +428,20 @@ format.")
               (patches (search-patches "mpc123-initialize-ao.patch"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:phases (alist-replace
-                 'configure
-                 (lambda _
-                   (substitute* "Makefile"
-                     (("CC[[:blank:]]*:=.*")
-                      "CC := gcc\n")))
-                 (alist-replace
-                  'install
-                  (lambda* (#:key outputs #:allow-other-keys)
-                    (let* ((out (assoc-ref outputs "out"))
-                           (bin (string-append out "/bin")))
-                      (mkdir-p bin)
-                      (install-file "mpc123" bin)))
-                  %standard-phases))
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'configure
+           (lambda _
+             (substitute* "Makefile"
+               (("CC[[:blank:]]*:=.*")
+                "CC := gcc\n"))))
+         (replace 'install
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (bin (string-append out "/bin")))
+               (mkdir-p bin)
+               (install-file "mpc123" bin)))))
        #:tests? #f))
-
     (native-inputs
      `(("gettext" ,gnu-gettext)))
     (inputs