summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-15 21:30:18 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-24 20:44:30 +0100
commit1c4746ee6926861543d28a4cd5e0fd60ea01938d (patch)
treeaa43e9c61694f017be50bcef11a332d33fe647f6 /gnu/packages
parent5e1d6787f2b11c28e861de9314f4a76d50b935be (diff)
downloadguix-1c4746ee6926861543d28a4cd5e0fd60ea01938d.tar.gz
gnu: python-setuptools-scm: Update to 3.3.3.
* gnu/packages/python-xyz.scm (python-setuptools-scm): Update to 3.3.3.
(python-setuptools-scm-3.3): Remove variable.
(python-lazy-object-proxy)[native-inputs]: Change from
PYTHON-SETUPTOOLS-SCM-3.3 to PYTHON-SETUPTOOLS-SCM.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 3 insertions, 15 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 47da29627a..62c407c65e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4930,13 +4930,13 @@ child application and control it as if a human were typing commands.")
 (define-public python-setuptools-scm
   (package
     (name "python-setuptools-scm")
-    (version "3.2.0")
+    (version "3.3.3")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "setuptools_scm" version))
               (sha256
                (base32
-                "0n3knn3p1sqlx31k2lahn7z9bacvlv8nhlfidj77vz50bxqlgasj"))))
+                "19cyndx23xmpbhz4qrwmfwsmnnaczd0dw7qg977ksq2dbvxy29dx"))))
     (build-system python-build-system)
     (home-page "https://github.com/pypa/setuptools_scm/")
     (synopsis "Manage Python package versions in SCM metadata")
@@ -4946,18 +4946,6 @@ child application and control it as if a human were typing commands.")
 them as the version argument or in a SCM managed file.")
     (license license:expat)))
 
-;; Needed by python-lazy-object-proxy, remove on next update cycle.
-(define-public python-setuptools-scm-3.3
-  (package
-    (inherit python-setuptools-scm)
-    (version "3.3.3")
-    (source (origin
-              (method url-fetch)
-              (uri (pypi-uri "setuptools_scm" version))
-              (sha256
-               (base32
-                "19cyndx23xmpbhz4qrwmfwsmnnaczd0dw7qg977ksq2dbvxy29dx"))))))
-
 (define-public python2-setuptools-scm
   (package-with-python2 python-setuptools-scm))
 
@@ -10666,7 +10654,7 @@ it will manage (install/update) them for you.")
                (base32
                 "1w1aaay424ciz8fz3fkzxb0pxzfxn184f2whpyn4fx72bn50x47k"))))
     (native-inputs
-     `(("python-setuptools-scm" ,python-setuptools-scm-3.3)))
+     `(("python-setuptools-scm" ,python-setuptools-scm)))
     (build-system python-build-system)
     (home-page "https://github.com/ionelmc/python-lazy-object-proxy")
     (synopsis "Lazy object proxy for python")