summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAdam Faiz <adam.faiz@disroot.org>2022-11-20 09:25:31 +0800
committerEfraim Flashner <efraim@flashner.co.il>2022-11-20 10:46:30 +0200
commit3d1a5a3ec74bab3ce2ddce23b51d5e869df94363 (patch)
tree269fed57cd6e62b05fe6896f3fd65d044aa1809f /gnu/packages
parentd09a4cc7c739f4201821623f62c69bcef9c20f52 (diff)
downloadguix-3d1a5a3ec74bab3ce2ddce23b51d5e869df94363.tar.gz
gnu: chipmunk: Fix build.
* gnu/packages/game-development.scm (chipmunk)[source]: Don't include
the <sys/sysctl.h> header. It has been removed in glibc since 2.32.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/game-development.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 90205a89ab..b319f2fef3 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -2444,7 +2444,14 @@ computer games, 3D authoring tools and simulation tools.")
              (commit (string-append "Chipmunk-" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1qmkn01g06p3rnhmbyffmjns6wj5vhgf9cscigk3wzxcpwv1hyxb"))))
+        (base32 "1qmkn01g06p3rnhmbyffmjns6wj5vhgf9cscigk3wzxcpwv1hyxb"))
+       (modules '((guix build utils)))
+       (snippet
+        #~(begin
+            ;; This is fixed in the upstream repository but the fix
+            ;; has not been released.
+            (substitute* "src/cpHastySpace.c"
+              (("#include <sys/sysctl.h>") ""))))))
     (build-system cmake-build-system)
     (arguments
      `(#:tests? #f                      ;no test