summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-12 18:02:05 +0100
committerMarius Bakke <marius@gnu.org>2022-01-12 23:50:16 +0100
commit5f7559efd49ca22fd8fc849f0ca10b1dd6c787a9 (patch)
tree9dfa8572cd7c206cba73d318b01d9d77807f556a /gnu/packages
parent4d10384f6435f657cd251cdca8d279b18b843ec2 (diff)
downloadguix-5f7559efd49ca22fd8fc849f0ca10b1dd6c787a9.tar.gz
gnu: python-isort: Update to 5.10.1.
* gnu/packages/python-xyz.scm (python-isort): Update to 5.10.1.
[arguments]: Add phase to support newer Black versions.  Install another
test plugin.
[native-inputs]: Add PYTHON-NATSORT.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2c332de983..2b37a4d560 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18437,7 +18437,7 @@ multitouch applications.")
 (define-public python-isort
   (package
     (name "python-isort")
-    (version "5.7.0")
+    (version "5.10.1")
     (source
      (origin
        (method git-fetch)
@@ -18450,11 +18450,17 @@ multitouch applications.")
        (snippet '(for-each delete-file (find-files "." "\\.whl$")))
        (sha256
         (base32
-         "0phq4s911mjjdyr5h5siz93jnpkqb2qgphgcfk6axncgxr8i7vi1"))))
+         "09spgl2k9xrprr5gbpfc91a8p7mx7a0c64ydgc91b3jhrmnd9jg1"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'loosen-requirements
+           (lambda _
+             ;; Permit newer versions of black.
+             (substitute* "example_isort_formatting_plugin/pyproject.toml"
+               (("\\^20\\.08b1")
+                ">= 20.08b1"))))
          ;; A foretaste of what our future python-build-system will need to
          ;; do.
          (replace 'build
@@ -18471,6 +18477,7 @@ multitouch applications.")
              (let ((out (assoc-ref outputs "out")))
                ;; Patch to use the core poetry API.
                (substitute* '("example_isort_formatting_plugin/pyproject.toml"
+                              "example_isort_sorting_plugin/pyproject.toml"
                               "example_shared_isort_profile/pyproject.toml")
                  (("poetry>=0.12")
                   "poetry-core>=1.0.0")
@@ -18482,6 +18489,7 @@ multitouch applications.")
                                    "--no-isolation" "--outdir=dist"
                                    source-directory))
                          '("example_isort_formatting_plugin"
+                           "example_isort_sorting_plugin"
                            "example_shared_isort_profile"))
                ;; Install them to temporary storage, for the test.
                (setenv "HOME" (getcwd))
@@ -18502,6 +18510,7 @@ multitouch applications.")
        ("python-colorama" ,python-colorama)
        ("python-hypothesmith" ,python-hypothesmith)
        ("python-libcst" ,python-libcst-minimal)
+       ("python-natsort" ,python-natsort)
        ("python-poetry-core" ,python-poetry-core)
        ("python-pylama" ,python-pylama)
        ("python-pypa-build" ,python-pypa-build)