summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-10-06 14:32:35 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-10-06 14:49:29 +0200
commit681bf1b2e68b2abe4f6d7f9ca52b5f505b5b82e8 (patch)
treea23fb35ba714840d857849cb23c23719918503ea /gnu/packages
parent9bb8a84623355abcedc9b020b5abfd6f2e48ebc9 (diff)
downloadguix-681bf1b2e68b2abe4f6d7f9ca52b5f505b5b82e8.tar.gz
gnu: libtsm: Remove bundled libxkbcommon header.
* gnu/packages/terminals.scm (libtsm)[source]: Snip xkbcommon-keysyms.h.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/terminals.scm26
1 files changed, 16 insertions, 10 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 4a9970b9fe..f24e89daec 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -221,16 +221,22 @@ text-based approach to terminal recording.")
     (package
       (name "libtsm")
       (version (git-version "0.0.0" revision commit))
-      (source (origin
-                (method git-fetch)
-                ;; The freedesktop repository is no longer maintained.
-                (uri (git-reference
-                      (url (string-append "https://github.com/Aetf/" name))
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "0mwn91i5h5d518i1s05y7hzv6bc13vzcvxszpfh77473iwg4wprx"))))
+      (source
+       (origin
+         (method git-fetch)
+         ;; The freedesktop repository is no longer maintained.
+         (uri (git-reference
+               (url (string-append "https://github.com/Aetf/" name))
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0mwn91i5h5d518i1s05y7hzv6bc13vzcvxszpfh77473iwg4wprx"))
+         (modules '((guix build utils)))
+         (snippet
+          '(begin
+             ;; Remove a bundled copy of libxkbcommon's xkbcommon-keysyms.h.
+             (delete-file-recursively "external/xkbcommon")
+             #t))))
       (build-system cmake-build-system)
       (arguments
        `(#:configure-flags '("-DBUILD_TESTING=ON")))