summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-09-29 15:28:40 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-09-30 12:39:34 +0200
commit7aed4f72b000f5c8fe327519c3d82d52ebe139e8 (patch)
tree4d4bc51a80d614e4bbdd84baa278dce32b7a8478 /gnu/packages
parent15dc56b0dd1b30eb60cd716810625409d0208c0f (diff)
downloadguix-7aed4f72b000f5c8fe327519c3d82d52ebe139e8.tar.gz
gnu: Add r-here.
* gnu/packages/cran.scm (r-here): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3e8b7e3924..6a059993ec 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -8045,6 +8045,28 @@ weak stationarity, column means by group, weighted biplots, and a heuristic to
 obtain a better initial configuration in non-metric MDS.")
     (license license:gpl2)))
 
+(define-public r-here
+  (package
+    (name "r-here")
+    (version "1.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "here" version))
+       (sha256
+        (base32 "0srlr8h8qmr0wrmp7gs4g2ry5dni2hx8n947bik3s3a26f091v88"))))
+    (properties `((upstream-name . "here")))
+    (build-system r-build-system)
+    (propagated-inputs `(("r-rprojroot" ,r-rprojroot)))
+    (native-inputs `(("r-knitr" ,r-knitr)))
+    (home-page "https://here.r-lib.org/")
+    (synopsis "Simpler way to find files")
+    (description
+     "This package lets you construct paths to your project's files.  Use the
+@code{here} function as a drop-in replacement for @code{file.path}, it will
+always locate the files relative to your project root.")
+    (license license:expat)))
+
 (define-public r-reticulate
   (package
     (name "r-reticulate")