summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-04-02 16:05:05 +0200
committerLudovic Courtès <ludo@gnu.org>2020-04-02 16:07:12 +0200
commita1a9d3848c4197f0e711e1d675771c82aa4dc200 (patch)
tree648bf0c47ece254cdb302d1a13094627d4e3453d /gnu/packages
parent9bdb0fee012cb8bae0080c3d398842cad612070a (diff)
downloadguix-a1a9d3848c4197f0e711e1d675771c82aa4dc200.tar.gz
gnu: mate-session-manager: Actually build with elogind support.
Fixes <https://bugs.gnu.org/40327>.
Reported by Jonathan Brielmaier <jonathan.brielmaier@web.de>.

This ensures one gets a "Shut Down" entry in the "System" menu.

* gnu/packages/mate.scm (mate-session-manager)[arguments]: Pass
"--with-elogind" instead of "--enable-elogind".  Remove 'pre-configure'
phase.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/mate.scm20
1 files changed, 1 insertions, 19 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index 28f6b1e76f..eaafc5db63 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -352,28 +352,10 @@ configurations (profiles).")
          "01scj5d1xlri9b2id8gm9kfni9nzhdjdf7rag7fvcxwqp7baz3h3"))))
     (build-system glib-or-gtk-build-system)
     (arguments
-     `(#:configure-flags (list "--enable-elogind"
+     `(#:configure-flags (list "--with-elogind"
                                "--disable-schemas-compile")
        #:phases
        (modify-phases %standard-phases
-         (add-before 'configure 'pre-configure
-           (lambda* (#:key outputs #:allow-other-keys)
-             ;; Use elogind instead of systemd.
-             (substitute* "configure"
-               (("libsystemd-login")
-                "libelogind")
-               (("systemd") "elogind"))
-             (substitute* "mate-session/gsm-systemd.c"
-               (("#include <systemd/sd-login.h>")
-                "#include <elogind/sd-login.h>"))
-             ;; Remove uses of the systemd journal.
-             (substitute* "mate-session/main.c"
-               (("#ifdef HAVE_SYSTEMD") "#if 0"))
-             (substitute* "mate-session/gsm-manager.c"
-               (("#ifdef HAVE_SYSTEMD") "#if 0"))
-             (substitute* "mate-session/gsm-autostart-app.c"
-               (("#ifdef HAVE_SYSTEMD") "#if 0"))
-             #t))
          (add-after 'install 'update-xsession-dot-desktop
            (lambda* (#:key outputs #:allow-other-keys)
              ;; Record the absolute file name of 'mate-session' in the