summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-22 11:32:07 +0100
committerMarius Bakke <marius@gnu.org>2022-01-22 12:42:48 +0100
commitd07a89d645be8172c0f9c707630c7b8d67ea7b5d (patch)
treeb3d26ddffa34559843a8ab8f3c859028ec67bcef /gnu/packages
parent74f38150981df1416e46b1fa6a2abf4f11e7281c (diff)
downloadguix-d07a89d645be8172c0f9c707630c7b8d67ea7b5d.tar.gz
gnu: Remove python-flask-script.
This package is not compatible with current versions of Flask and has been
obsoleted upstream.

* gnu/packages/python-web.scm (python-flask-script): Remove variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-web.scm34
1 files changed, 0 insertions, 34 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 483abec2d5..d2d1389d19 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3733,40 +3733,6 @@ this it tries to be opinion-free and very extendable.")
 server.")
     (license license:expat)))
 
-(define-public python-flask-script
-  (package
-  (name "python-flask-script")
-  (version "2.0.6")
-  (source
-    (origin
-      (method url-fetch)
-      (uri (pypi-uri "Flask-Script" version))
-      (sha256
-        (base32
-          "0r8w2v89nj6b9p91p495cga5m72a673l2wc0hp0zqk05j4yrc9b4"))))
-  (build-system python-build-system)
-  (arguments
-   `(#:phases
-     (modify-phases %standard-phases
-       (add-after 'unpack 'patch-tests
-         (lambda _
-           (substitute* "tests.py"
-            (("flask\\.ext\\.script") "flask_script"))
-           #t)))))
-  (propagated-inputs
-   (list python-flask python-argcomplete python-werkzeug))
-  (native-inputs
-   (list python-pytest))
-  (home-page
-    "https://github.com/smurfix/flask-script")
-  (synopsis "Scripting support for Flask")
-  (description "The Flask-Script extension provides support for writing
-external scripts in Flask.  This includes running a development server,
-a customised Python shell, scripts to set up your database, cronjobs,
-and other command-line tasks that belong outside the web application
-itself.")
-  (license license:bsd-3)))
-
 (define-public python-flask-migrate
   (package
     (name "python-flask-migrate")