summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2016-08-23 15:09:06 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2016-09-13 17:03:42 +0200
commitd15e2ef05a8fe711d5fda75c198c5299961d4716 (patch)
treed333020d45503afe172c688d0eaead4023f6eabd /gnu/packages
parentc033c1958d50e58d84b2ebb41b15040ed0f22431 (diff)
downloadguix-d15e2ef05a8fe711d5fda75c198c5299961d4716.tar.gz
gnu: python-prompt-toolkit: Update to 1.0.7.
* gnu/packages/python.scm (python-prompt-toolkit): Update to 1.0.7.
[source]: Use 'pypi-uri'.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b839f22989..e918149b41 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9750,17 +9750,14 @@ implementation for Python.")
 (define-public python-prompt-toolkit
  (package
   (name "python-prompt-toolkit")
-  (version "1.0.3")
+  (version "1.0.7")
   (source
     (origin
       (method url-fetch)
-      (uri (string-append
-             "https://pypi.python.org/packages/"
-             "8d/de/412f23919929c01e6b55183e124623f705e4b91796d3d2dce2cb53d595ad/"
-             "prompt_toolkit-" version ".tar.gz"))
+      (uri (pypi-uri "prompt_toolkit" version ".tar.gz"))
       (sha256
         (base32
-          "18lbmmkyjf509klc3217lq0x863pfzix779zx5kp9lms1iph4pl0"))))
+          "1vyjd0b7wciv55i19l44zy0adx8q7ss79lhy2r9d1rwz2y4822zg"))))
   (build-system python-build-system)
   (inputs `(("python-wcwidth" ,python-wcwidth)
             ("python-pygments" ,python-pygments)))