summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-05-19 10:50:20 +0200
committerLudovic Courtès <ludo@gnu.org>2017-05-19 10:50:20 +0200
commite7fbd49132406bb9ec12141ac77ac401f58ee267 (patch)
treec11fc06d12dba52e12f596fba146cc287e09826d /gnu/packages
parent7afc2aabdf2041faac1d1adfc5752f1e92d29822 (diff)
downloadguix-e7fbd49132406bb9ec12141ac77ac401f58ee267.tar.gz
gnu: guile-ssh: Fix potential double-free/use-after-free issue.
Fixes <http://bugs.gnu.org/26976>.
Reported by Mark H Weaver <mhw@netris.org>.

* gnu/packages/patches/guile-ssh-double-free.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/ssh.scm (guile-ssh)[source](patches): Add it.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/patches/guile-ssh-double-free.patch37
-rw-r--r--gnu/packages/ssh.scm3
2 files changed, 39 insertions, 1 deletions
diff --git a/gnu/packages/patches/guile-ssh-double-free.patch b/gnu/packages/patches/guile-ssh-double-free.patch
new file mode 100644
index 0000000000..9692b81d39
--- /dev/null
+++ b/gnu/packages/patches/guile-ssh-double-free.patch
@@ -0,0 +1,37 @@
+Fix a double-free or use-after-free issue with Guile-SSH used
+with Guile 2.2.  See <https://bugs.gnu.org/26976>.
+
+diff --git a/libguile-ssh/channel-type.c b/libguile-ssh/channel-type.c
+index 3dd641f..0839854 100644
+--- a/libguile-ssh/channel-type.c
++++ b/libguile-ssh/channel-type.c
+@@ -229,10 +229,11 @@ ptob_close (SCM channel)
+       ssh_channel_free (ch->ssh_channel);
+     }
+ 
++  SCM_SETSTREAM (channel, NULL);
++
+ #if USING_GUILE_BEFORE_2_2
+   scm_gc_free (pt->write_buf, pt->write_buf_size, "port write buffer");
+   scm_gc_free (pt->read_buf,  pt->read_buf_size, "port read buffer");
+-  SCM_SETSTREAM (channel, NULL);
+ 
+   return 0;
+ #endif
+diff --git a/libguile-ssh/sftp-file-type.c b/libguile-ssh/sftp-file-type.c
+index 8879924..f87cf03 100644
+--- a/libguile-ssh/sftp-file-type.c
++++ b/libguile-ssh/sftp-file-type.c
+@@ -224,10 +224,11 @@ ptob_close (SCM sftp_file)
+       sftp_close (fd->file);
+     }
+ 
++  SCM_SETSTREAM (sftp_file, NULL);
++
+ #if USING_GUILE_BEFORE_2_2
+   scm_gc_free (pt->write_buf, pt->write_buf_size, "port write buffer");
+   scm_gc_free (pt->read_buf,  pt->read_buf_size, "port read buffer");
+-  SCM_SETSTREAM (sftp_file, NULL);
+ 
+   return 1;
+ #endif
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 6a074d10fa..bb1898774b 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -226,7 +226,8 @@ Additionally, various channel-specific options can be negotiated.")
               (sha256
                (base32
                 "0r261i8kc3avbmbwgyzak2vnqwssjlgz37g2y2fwm80w9bmn2m7j"))
-              (patches (search-patches "guile-ssh-rexec-bug.patch"))
+              (patches (search-patches "guile-ssh-rexec-bug.patch"
+                                       "guile-ssh-double-free.patch"))
               (modules '((guix build utils)))
               (snippet
                ;; 'configure.ac' mistakenly tries to link files from examples/