summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorCarlo Zancanaro <carlo@zancanaro.id.au>2017-11-06 22:39:11 +1100
committerLudovic Courtès <ludo@gnu.org>2017-11-07 00:12:10 +0100
commitea0421bbf6b4f0fcd2418d0a96e53eb4339574b5 (patch)
treeb5e520e452bccaa8eeee43d44fecfbd01dc6d772 /gnu/packages
parent8e57e416c0a6431a14d487ff8b69dece76d37c03 (diff)
downloadguix-ea0421bbf6b4f0fcd2418d0a96e53eb4339574b5.tar.gz
gnu: Add python-jsonrpclib-pelix.
* gnu/packages/python.scm (python-jsonrpclib-pelix, python2-jsonrpclib-pelix):
New variables.

Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e506f6dfd3..5b11a6371c 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -16897,3 +16897,27 @@ embeddable JavaScript engine.")
 
 (define-public python2-dukpy
   (package-with-python2 python-dukpy))
+
+(define-public python-jsonrpclib-pelix
+  (package
+    (name "python-jsonrpclib-pelix")
+    (version "0.3.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "jsonrpclib-pelix" version))
+       (sha256
+        (base32
+         "1qs95vxplxwspbrqy8bvc195s58iy43qkf75yrjfql2sim8b25sl"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/tcalmant/jsonrpclib/")
+    (synopsis "JSON-RPC 2.0 client library for Python")
+    (description
+     "This library implements the JSON-RPC v2.0
+specification (backwards-compatible) as a client library for Python.  This
+version is a fork of jsonrpclib by Josh Marshall, usable with Pelix remote
+services.")
+    (license license:asl2.0)))
+
+(define-public python2-jsonrpclib-pelix
+  (package-with-python2 python-jsonrpclib-pelix))