summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-02-27 19:49:03 +0100
committerLars-Dominik Braun <lars@6xq.net>2023-02-27 19:49:31 +0100
commit086e426d20e84be90f2066b4b5d51f24df7441cf (patch)
treefc09c81de2939fb9356d97a467b70fd06a704048 /gnu/packages
parent29a278f65c39032fa8ab503ba603b1c226068aa4 (diff)
downloadguix-086e426d20e84be90f2066b4b5d51f24df7441cf.tar.gz
gnu: ghc: Disable failing test on i686
Conditionally, so we don’t rebuild GHC on amd64.

* gnu/packages/haskell.scm (ghc-9.2)[arguments]: Conditionally add phase
'skip-T21694-i686.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 3406161c7c..16f4e2d530 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1296,7 +1296,16 @@ interactive environment for the functional language Haskell.")
              (replace 'fix-cc-reference
                (lambda _
                  (substitute* "utils/hsc2hs/src/Common.hs"
-                   (("\"cc\"") "\"gcc\""))))))
+                   (("\"cc\"") "\"gcc\""))))
+             ;; FIXME: Remove i686-specific match on the next rebuild cycle.
+             #$@(match (%current-system)
+                  ("i686-linux"
+                    #~((add-after 'skip-more-tests 'skip-T21694-i686
+                        (lambda _
+                          (substitute* '("testsuite/tests/simplCore/should_compile/all.T")
+                            (("^test\\('T21694', \\[ " all)
+                             (string-append all "when(arch('i386'), skip), ")))))))
+                  (_ #~()))))
          ;; Increase verbosity, so running the test suite does not time out on CI.
          ((#:make-flags make-flags ''())
           #~(cons "VERBOSE=4" #$make-flags))))