summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-08-26 07:55:01 +0200
committerMarius Bakke <marius@gnu.org>2022-11-21 22:01:09 +0100
commit10fdd4265cebf3e95a99e842a3741839a4982b74 (patch)
tree58db175c78dbb127c76845d31a87eb12abee4430 /gnu/packages
parente528b5eea34a39d944cdb11900a49f68dd396c54 (diff)
downloadguix-10fdd4265cebf3e95a99e842a3741839a4982b74.tar.gz
gnu: Add kwrited.
* gnu/packages/kde-plasma.scm (kwrited): New variable.

Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/kde-plasma.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 32fd21da0d..4f4c882a32 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -545,3 +545,24 @@ wayland-server API.")
 KDE Frameworks components.")
     (home-page "https://invent.kde.org/plasma/kwayland-integration")
     (license (list license:lgpl2.1 license:lgpl3))))
+
+(define-public kwrited
+  (package
+    (name "kwrited")
+    (version "5.25.5")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://kde/stable/plasma/"
+                                  version "/" name "-"
+                                  version ".tar.xz"))
+              (sha256
+               (base32
+                "03gw3czdgyf35n6x79x416rk6f7w1ayzmy5pb65v9733nx1j34mh"))))
+    (build-system qt-build-system)
+    (native-inputs (list extra-cmake-modules))
+    (inputs (list kcoreaddons ki18n kpty knotifications))
+    (home-page "https://invent.kde.org/plasma/kwrited")
+    (synopsis "System notification daemon")
+    (description
+     "This package provides a daemon that listens to system notifications.")
+    (license license:gpl2+)))