summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-22 09:48:11 +0100
committerMarius Bakke <marius@gnu.org>2022-01-22 10:23:01 +0100
commit515854b31f22d26da6de1aefa3602cab10491a45 (patch)
treef0b065e94a335697deb3050fa8317c79516021db /gnu/packages
parented9ca9740986a3738398dbb132aca18a6b0245d2 (diff)
downloadguix-515854b31f22d26da6de1aefa3602cab10491a45.tar.gz
gnu: python-flask-oidc: Update to 1.4.0.
* gnu/packages/python-web.scm (python-flask-oidc): Update to 1.4.0.
[arguments]: Override check phase.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-web.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 232d6f0137..c6e760ce35 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3609,15 +3609,22 @@ library for Python")
 (define-public python-flask-oidc
   (package
     (name "python-flask-oidc")
-    (version "1.1.1")
+    (version "1.4.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "flask-oidc" version))
        (sha256
         (base32
-         "1ay5j0mf174bix7i67hclr95gv16z81fpx0dijvi0gydvdj3ddy2"))))
+         "0klgwpn2iy5y7011xh2c8zkryxdwkpxh7qjs3hp5cynl748ia4hc"))))
     (build-system python-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (replace 'check
+                 (lambda* (#:key tests? #:allow-other-keys)
+                   (when tests?
+                     (invoke "nosetests")))))))
     (propagated-inputs
      (list python-flask python-itsdangerous python-oauth2client
            python-six))