summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDomagoj Stolfa <domagoj.stolfa@gmail.com>2021-07-11 15:55:34 +0100
committerEfraim Flashner <efraim@flashner.co.il>2021-07-13 15:14:14 +0300
commit6d5d4659261ee3fb565f111f5d9789b0be153900 (patch)
treeafb7b71a98d3f713a82b63a2a7fabc99873ccd43 /gnu/packages
parentb12fbd1b8afc13f651e277e44e99edb68548de5c (diff)
downloadguix-6d5d4659261ee3fb565f111f5d9789b0be153900.tar.gz
gnu: Add rust-postgres-derive-0.4.
* gnu/packages/crates-io.scm (rust-postgres-derive-0.4): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 3fa06dc8a4..d12cf539ff 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -32710,6 +32710,30 @@ UDP.")
      "This package provides a native, synchronous PostgreSQL client.")
     (license license:expat)))
 
+(define-public rust-postgres-derive-0.4
+  (package
+    (name "rust-postgres-derive")
+    (version "0.4.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "postgres-derive" version))
+        (file-name
+         (string-append name "-" version ".tar.gz"))
+        (sha256
+         (base32 "0xqlf1gffy3q8hra3fm0vm9x8i5fkvi0qjl99d0xirxh3hidsmy8"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-proc-macro2" ,rust-proc-macro2-1)
+        ("rust-quote" ,rust-quote-1)
+        ("rust-syn" ,rust-syn-1))))
+    (home-page "https://github.com/sfackler/rust-postgres")
+    (synopsis "Internal crate used by postgres-types")
+    (description
+     "This is an internal crate used by postgres-types.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-postgres-protocol-0.3
   (package
     (name "rust-postgres-protocol")