summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-04 16:07:13 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-04 16:34:32 +0300
commit7aad3dea66ccaf671f19167c350b10ddc68bba27 (patch)
treeaa2ff62d765a54e8db3562b376d346249d93db40 /gnu/packages
parentbc38598c8eb8b7df125c16a38ae4c1180e1f6979 (diff)
downloadguix-7aad3dea66ccaf671f19167c350b10ddc68bba27.tar.gz
gnu: tevent: Update to 0.11.0.
* gnu/packages/samba.scm (tevent): Update to 0.11.0.
[native-inputs]: Add cmocka.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/samba.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index fd67e4b8ba..f9b20ccd47 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -1,7 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013, 2015, 2017 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2016, 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2019, 2021 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 Adonay "adfeno" Felipe Nogueira <https://libreplanet.org/wiki/User:Adfeno> <adfeno@openmailbox.org>
 ;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
 ;;; Copyright © 2017, 2018, 2020 Marius Bakke <mbakke@fastmail.com>
@@ -348,14 +348,14 @@ destructors.  It is the core memory allocator used in Samba.")
 (define-public tevent
   (package
     (name "tevent")
-    (version "0.10.2")
+    (version "0.11.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://www.samba.org/ftp/tevent/tevent-"
                                   version ".tar.gz"))
               (sha256
                (base32
-                "15k6i8ad5lpxfjsjyq9h64zlyws8d3cm0vwdnaw8z1xjwli7hhpq"))))
+                "1fl2pj4p8p5fa2laykwf1sfjdw7pkw9slklj3vzc5ah8x348d6pf"))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases
@@ -368,7 +368,8 @@ destructors.  It is the core memory allocator used in Samba.")
                        (string-append "--prefix=" out)
                        "--bundled-libraries=NONE")))))))
     (native-inputs
-     `(("pkg-config" ,pkg-config)
+     `(("cmocka" ,cmocka)
+       ("pkg-config" ,pkg-config)
        ("python" ,python)
        ("which" ,which)))
     (propagated-inputs