summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2023-01-12 09:18:27 +0100
committerMarius Bakke <marius@gnu.org>2023-01-13 03:19:40 +0100
commit8f18bad2aa03d9d940bc71d161203546a0576dfe (patch)
tree7f19e192571671eaf7ae48c95f6d1bec14624018 /gnu/packages
parentffb9813aeebaf74a3808e7c6731c7eaaafc9379f (diff)
downloadguix-8f18bad2aa03d9d940bc71d161203546a0576dfe.tar.gz
gnu: rdma-core: Remove input labels.
* gnu/packages/linux.scm (rdma-core)[arguments]: Don't reference rst2man by
label.  Reindent.
[native-inputs, inputs]: Remove labels.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm24
1 files changed, 10 insertions, 14 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1d523233da..71e53ee401 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -6521,23 +6521,23 @@ from the ntfs-3g package.  It is meant to be used in initrds.")
                 "1rah0v9gq9rksqd2c17nmydsxcjz178n7m2y4ricwlf5pq1b2yfi"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:tests? #f ; no tests
+     `(#:tests? #f                      ;no tests
+
        ;; Upstream uses the "ninja" build system and encourage distros
        ;; to do the same for consistency.
        #:configure-flags (list "-GNinja"
 
                                ,@(if (%current-target-system)
-                                   `((string-append
-                                       "-DPKG_CONFIG_EXECUTABLE="
-                                       (search-input-file
+                                     `((string-append
+                                        "-DPKG_CONFIG_EXECUTABLE="
+                                        (search-input-file
                                          %build-inputs
                                          (string-append "/bin/"
                                                         ,(pkg-config-for-target)))))
-                                   '())
+                                     '())
                                (string-append "-DRST2MAN_EXECUTABLE="
-                                              (assoc-ref %build-inputs
-                                                         "python-docutils")
-                                              "/bin/rst2man.py"))
+                                              (search-input-file
+                                               %build-inputs "/bin/rst2man.py")))
        #:phases
        (modify-phases %standard-phases
          (replace 'build
@@ -6548,13 +6548,9 @@ from the ntfs-3g package.  It is meant to be used in initrds.")
            (lambda _
              (invoke "ninja" "install"))))))
     (native-inputs
-     `(("ninja" ,ninja)
-       ("pkg-config" ,pkg-config)
-       ("python" ,python-wrapper)
-       ("python-docutils" ,python-docutils)))     ;for 'rst2man'
+     (list ninja pkg-config python-wrapper python-docutils)) ;for 'rst2man'
     (inputs
-     `(("libnl" ,libnl)
-       ("udev" ,eudev)))
+     (list libnl eudev))
     (home-page "https://github.com/linux-rdma/rdma-core")
     (synopsis "Utilities and libraries for working with RDMA devices")
     (description