summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-09-19 12:54:40 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-09-19 12:54:40 +0300
commit9b30301efee6ccb1270284ee7eea99151f87e6f4 (patch)
tree21f0ac07705f9c5bbafa1517cba85380f2d4b701 /gnu/packages
parent2266ec5eb1bcc2c87baa27297a4205eebf325424 (diff)
downloadguix-9b30301efee6ccb1270284ee7eea99151f87e6f4.tar.gz
gnu: python-websockets: Extend test timeout.
* gnu/packages/python-web.scm (python-websockets)[arguments]: Add phase
to extend the tests timeout so slower machines can complete them.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-web.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 255c5d67ec..41a72089ec 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5671,6 +5671,12 @@ files.")
         (base32
          "1vk7g5z977mi89hamwiqawpmibwvv9ghrf3pqva1waxmyc7gyjb5"))))
     (build-system python-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-before 'check 'extend-test-timeout
+                 (lambda _
+                   (setenv "WEBSOCKETS_TESTS_TIMEOUT_FACTOR" "10"))))))
     (home-page "https://github.com/aaugustin/websockets")
     (synopsis
      "Python implementation of the WebSocket Protocol (RFC 6455 & 7692)")