summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-11-20 01:00:00 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-11-27 01:00:09 +0100
commite206036f387caee2e6f8ff74aa415f8a9a639621 (patch)
treec93f51c80c5d919c528f43cfe7249490afa39316 /gnu/packages
parent2bb8bf36a51326cfd6ca5099d0f668a642b67d88 (diff)
downloadguix-e206036f387caee2e6f8ff74aa415f8a9a639621.tar.gz
gnu: powertop: Refactor regexp.
* gnu/packages/linux.scm (powertop)[arguments]:
Factor out substitute* regexp.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 135fb20999..8086980901 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3179,9 +3179,8 @@ devices.  It replaces @code{iwconfig}, which is deprecated.")
                  ;; These programs are only needed to calibrate, so using
                  ;; relative file names avoids adding extra inputs.  When they
                  ;; are missing powertop gracefully handles it.
-                 (("/usr/bin/hcitool") "hcitool")
-                 (("/usr/bin/xset") "xset")
-                 (("/usr/sbin/hciconfig") "hciconfig"))))))))
+                 (("/usr/s?bin/(hciconfig|hcitool|xset)" _ command)
+                  command))))))))
     (native-inputs
      (list autoconf
            autoconf-archive