summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2023-03-08 16:53:22 +0100
committerJosselin Poiret <dev@jpoiret.xyz>2023-06-04 10:59:31 +0200
commitfe6c31e3338f73f94fcbe6fc6ff8b7543762060e (patch)
tree17a951b8693e4d3aa2d41dfb2e364857065f5ad3 /gnu/packages
parent789db27c51501e77ac7be0411e1f979234cf02f5 (diff)
downloadguix-fe6c31e3338f73f94fcbe6fc6ff8b7543762060e.tar.gz
gnu: emacs-agda2-mode: No longer inherit from agda.
* gnu/packages/agda.scm (emacs-agda2-mode): Remove it. Made no sense, as we only
need the source, which we can refer to without inheriting the whole thing.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/agda.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/agda.scm b/gnu/packages/agda.scm
index 7a28f69a0d..9dfcc907ec 100644
--- a/gnu/packages/agda.scm
+++ b/gnu/packages/agda.scm
@@ -129,10 +129,10 @@ such as Coq, Epigram and NuPRL.")
 
 (define-public emacs-agda2-mode
   (package
-    (inherit agda)
     (name "emacs-agda2-mode")
+    (version (package-version agda))
+    (source (package-source agda))
     (build-system emacs-build-system)
-    (inputs '())
     (arguments
      `(#:phases
        (modify-phases %standard-phases
@@ -141,7 +141,8 @@ such as Coq, Epigram and NuPRL.")
     (home-page "https://agda.readthedocs.io/en/latest/tools/emacs-mode.html")
     (synopsis "Emacs mode for Agda")
     (description "This Emacs mode enables interactive development with
-Agda.  It also aids the input of Unicode characters.")))
+Agda.  It also aids the input of Unicode characters.")
+    (license (package-license agda))))
 
 (define-public agda-ial
   (package