summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-05-30 20:58:34 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-06-14 14:52:22 +0300
commit04cf30e15323fa56c1f0ce7e4e8f3981dab9f99a (patch)
treedf8984f5b2e7169a0ae3e43d1dc424b5f575c6c6 /gnu/packages
parent8c1171da28b7f7bb42cfd11de428249b4e396a8e (diff)
downloadguix-04cf30e15323fa56c1f0ce7e4e8f3981dab9f99a.tar.gz
gnu: Add python-stsci-image.
* gnu/packages/astronomy.scm (python-stsci-image): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/astronomy.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 4bca7cf4e0..80bf8a68f8 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2045,6 +2045,34 @@ spherical polygons that represent arbitrary regions of the sky.")
     ;; QD_LIBRARY_LICENSE.rst for bandeled QD source
     (license license:bsd-3)))
 
+(define-public python-stsci-image
+  (package
+    (name "python-stsci-image")
+    (version "2.3.5")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "stsci.image" version))
+              (sha256
+               (base32
+                "1vnp4256nbdvapa69cmm80sjz11ygxa49abr9nbvssj6nyyp5icb"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list #:phases #~(modify-phases %standard-phases
+                        (add-before 'check 'build-extensions
+                          (lambda _
+                            ;; Cython extensions have to be built before running
+                            ;; the tests.
+                            (invoke "python" "setup.py" "build_ext"
+                                    "--inplace"))))))
+    (propagated-inputs (list python-numpy python-scipy))
+    (native-inputs (list python-pytest python-setuptools-scm))
+    (home-page "https://github.com/spacetelescope/stsci.image")
+    (synopsis "Image array manipulation functions")
+    (description
+     "This package provides Python modules of @acronym{STScI, Space Telescope
+Science Institute} image array manipulation functions.")
+    (license license:bsd-3)))
+
 (define-public libnova
   (package
     (name "libnova")