summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-07-13 12:29:51 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-07-18 20:56:17 +0300
commit104895fb4981d32684333789ece3f0c09ebe5d68 (patch)
treeee9da541de8e79592a05a298e2de666e947bbb79 /gnu/packages
parent976f018e652eb963732c9208aa4a4cd08f7da888 (diff)
downloadguix-104895fb4981d32684333789ece3f0c09ebe5d68.tar.gz
gnu: Add rust-hashbrown-0.14.
* gnu/packages/crates-io.scm (rust-hashbrown-0.14): New variable.
(rust-hashbrown-0.13): Inherit from rust-hashbrown-0.14.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm50
1 files changed, 44 insertions, 6 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index e4834f8958..58cf2e23df 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -27845,40 +27845,78 @@ already-hashed or hash-like data.")
 @code{#[derive(Hash32)]}.")
     (license (list license:expat license:asl2.0))))
 
-(define-public rust-hashbrown-0.13
+(define-public rust-hashbrown-0.14
   (package
     (name "rust-hashbrown")
-    (version "0.13.2")
+    (version "0.14.0")
     (source (origin
               (method url-fetch)
               (uri (crate-uri "hashbrown" version))
               (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
-                "03ji3n19j4b6mf2wlla81vsixcmlivglp6hgk79d1pcxfcrw38s3"))))
+                "0yj3nf0w30pf30w503kgaw4sbjnh62l5cbmc7dd0mnczzywh2qic"))
+              (modules '((guix build utils)))
+              (snippet
+               '(begin
+                  (substitute* "Cargo.toml"
+                    (("=([[:digit:]]+\\.[[:digit:]]+\\.[[:digit:]]+)" _ version)
+                     (string-append "^" version)))))))
     (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
        (("rust-ahash" ,rust-ahash-0.8)
-        ("rust-bumpalo" ,rust-bumpalo-3)
+        ("rust-allocator-api2" ,rust-allocator-api2-0.2)
         ("rust-compiler-builtins" ,rust-compiler-builtins-0.1)
         ("rust-rayon" ,rust-rayon-1)
+        ("rust-rkyv" ,rust-rkyv-0.7)
         ("rust-rustc-std-workspace-alloc" ,rust-rustc-std-workspace-alloc-1)
         ("rust-rustc-std-workspace-core" ,rust-rustc-std-workspace-core-1)
         ("rust-serde" ,rust-serde-1))
        #:cargo-development-inputs
-       (("rust-doc-comment" ,rust-doc-comment-0.3)
+       (("rust-bumpalo" ,rust-bumpalo-3)
+        ("rust-doc-comment" ,rust-doc-comment-0.3)
         ("rust-fnv" ,rust-fnv-1)
         ("rust-lazy-static" ,rust-lazy-static-1)
         ("rust-rand" ,rust-rand-0.8)
         ("rust-rayon" ,rust-rayon-1)
+        ("rust-rkyv" ,rust-rkyv-0.7)
         ("rust-serde-test" ,rust-serde-test-1))))
     (home-page "https://github.com/rust-lang/hashbrown")
     (synopsis "Rust port of Google's SwissTable hash map")
     (description
-     "This package provides a Rust port of Google's SwissTable hash map")
+     "This package provides a Rust port of Google's SwissTable hash map.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-hashbrown-0.13
+  (package
+    (inherit rust-hashbrown-0.14)
+    (name "rust-hashbrown")
+    (version "0.13.2")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "hashbrown" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "03ji3n19j4b6mf2wlla81vsixcmlivglp6hgk79d1pcxfcrw38s3"))))
+    (arguments
+     `(#:cargo-inputs
+       (("rust-ahash" ,rust-ahash-0.8)
+        ("rust-bumpalo" ,rust-bumpalo-3)
+        ("rust-compiler-builtins" ,rust-compiler-builtins-0.1)
+        ("rust-rayon" ,rust-rayon-1)
+        ("rust-rustc-std-workspace-alloc" ,rust-rustc-std-workspace-alloc-1)
+        ("rust-rustc-std-workspace-core" ,rust-rustc-std-workspace-core-1)
+        ("rust-serde" ,rust-serde-1))
+       #:cargo-development-inputs
+       (("rust-doc-comment" ,rust-doc-comment-0.3)
+        ("rust-fnv" ,rust-fnv-1)
+        ("rust-lazy-static" ,rust-lazy-static-1)
+        ("rust-rand" ,rust-rand-0.8)
+        ("rust-rayon" ,rust-rayon-1)
+        ("rust-serde-test" ,rust-serde-test-1))))))
+
 (define-public rust-hashbrown-0.12
   (package
     (inherit rust-hashbrown-0.13)