summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2021-05-27 13:30:48 +0200
committerRoel Janssen <roel@gnu.org>2021-05-27 13:30:48 +0200
commit12392cff5063c01b8de870ceae99e6e8fbec546f (patch)
tree4ea4d91110e2f98ed22443e7a5d930d59dd0f068 /gnu/packages
parentc555f54af5faefdfeb9f00abd50c9b82aefe572f (diff)
downloadguix-12392cff5063c01b8de870ceae99e6e8fbec546f.tar.gz
gnu: Add r-princurve.
* gnu/packages/cran.scm (r-princurve): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index e0b26e870f..894f2bc4d7 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -3475,6 +3475,25 @@ statistical functions and other utilities to ease their usage.")
 quantities.")
     (license license:expat)))
 
+(define-public r-princurve
+  (package
+   (name "r-princurve")
+   (version "2.1.6")
+   (source (origin
+            (method url-fetch)
+            (uri (cran-uri "princurve" version))
+            (sha256
+             (base32
+              "0wzk329bxljkzz57y220lsfckpsn45w348m6dcxh29zbj0ik65h2"))))
+   (build-system r-build-system)
+   (propagated-inputs
+    `(("r-rcpp" ,r-rcpp)))
+   (home-page "https://github.com/rcannood/princurve")
+   (synopsis "Fit a principal curve in arbitrary dimension")
+   (description "This package provides procedures for fitting a principal
+curve to a data matrix in arbitrary dimensions.")
+   (license license:gpl2)))
+
 (define-public r-reshape
   (package
     (name "r-reshape")