summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-04-30 21:20:52 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-05-01 00:30:21 +0300
commit1ab846181f0d068f071962c596ac4173761f5c6e (patch)
tree1ca90606fe72af58b47b882eff78ee3354f531f4 /gnu/packages
parent08675129aae260cb25cd6287e775cfe24bd92584 (diff)
downloadguix-1ab846181f0d068f071962c596ac4173761f5c6e.tar.gz
gnu: inkscape: Skip more tests on some architectures.
* gnu/packages/inkscape.scm (inkscape)[arguments]: Add a phase when
building for aarch64-linux or powerpc64le-linux to skip some more tests.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/inkscape.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/inkscape.scm b/gnu/packages/inkscape.scm
index b4b35dc251..2840fd789b 100644
--- a/gnu/packages/inkscape.scm
+++ b/gnu/packages/inkscape.scm
@@ -7,6 +7,7 @@
 ;;; Copyright © 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2020 Boris A. Dekshteyn <boris.dekshteyn@gmail.com>
 ;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
+;;; Copyright © 2023 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -192,6 +193,23 @@ endif()~%~%"
                 (("text-glyphs-combining") "")
                 (("text-glyphs-vertical") "")
                 (("test-rtl-vertical") ""))))
+          ,@(if (or (target-aarch64?)
+                    (target-ppc64le?))
+              `((add-after 'unpack 'disable-more-tests
+                  (lambda _
+                    ;; https://gitlab.com/inkscape/inkscape/-/issues/3554#note_1035680690
+                    (substitute* "testfiles/CMakeLists.txt"
+                      (("lpe64-test") "#lpe64-test"))
+                    ;; https://gitlab.com/inkscape/inkscape/-/issues/3554#note_1035539888
+                    ;; According to upstream, this is a false positive.
+                    (substitute* "testfiles/rendering_tests/CMakeLists.txt"
+                      (("test-use") "#test-use"))
+                    ;; https://gitlab.com/inkscape/inkscape/-/issues/3554#note_1035539888
+                    ;; Allegedly a precision error in the gamma.
+                    (substitute* "testfiles/cli_tests/CMakeLists.txt"
+                      (("add_cli_test\\(export-png-color-mode-gray-8_png" all)
+                       (string-append "#" all))))))
+              '())
           (add-after 'unpack 'set-home
             ;; Mute Inkscape warnings during tests.
             (lambda _