summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:26:35 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:09 +0200
commit26ff7a323c7caed82b62fd22fe2db46a0ab130ce (patch)
tree5bea55c997b919269dfdc51d1c229ae1e9d56169 /gnu/packages
parentca8ddaaa666c0235dc4054b7c6404c9e8f6c93fb (diff)
downloadguix-26ff7a323c7caed82b62fd22fe2db46a0ab130ce.tar.gz
gnu: emacs-mustache: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-mustache)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b250dcc5c2..5f0470c0fa 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6861,15 +6861,15 @@ to org file, you can use this tool to write orgify commentary.")
   (package
     (name "emacs-mustache")
     (version "0.23")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://github.com/Wilfred/mustache.el/archive/"
-                    version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "0k9lcgil7kykkv1ylrgwy1g13ldjjmgi2cwmysgyb2vlj3jbwpdj"))))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/Wilfred/mustache.el.git")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1n2ymd92qpvsby6ms0l3kjhdzzc47rri2aiscc6bs07hm4mjpr9q"))))
     (build-system emacs-build-system)
     (propagated-inputs
      `(("emacs-dash" ,emacs-dash)