summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-02-18 17:48:15 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-02-18 17:52:05 +0100
commit281df0d225877bf784c562cbdec0400f7f4c4513 (patch)
tree88d8f2480418951c4f85069c18a9aefc5a8507b1 /gnu/packages
parent8dac2e0d1e2486f68ef8348c415a962035fc9f41 (diff)
downloadguix-281df0d225877bf784c562cbdec0400f7f4c4513.tar.gz
gnu: Add r-sass.
* gnu/packages/cran.scm (r-sass): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 0daf67eabc..c385066694 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1403,6 +1403,36 @@ rmarkdown, etc.) depend on this package to avoid bundling redundant copies of
 jQuery.")
     (license license:expat)))
 
+(define-public r-sass
+  (package
+    (name "r-sass")
+    (version "0.3.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "sass" version))
+       (sha256
+        (base32
+         "1cxqwsdyz71mgflqqa65mfr161jlv8q9mshs1y19pxp6pz5wnv0s"))))
+    (properties `((upstream-name . "sass")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-digest" ,r-digest)
+       ("r-fs" ,r-fs)
+       ("r-htmltools" ,r-htmltools)
+       ("r-r6" ,r-r6)
+       ("r-rappdirs" ,r-rappdirs)
+       ("r-rlang" ,r-rlang)))
+    (native-inputs `(("r-knitr" ,r-knitr)))
+    (home-page "https://github.com/rstudio/sass")
+    (synopsis "Syntactically Awesome Style Sheets (SASS)")
+    (description
+     "This package provides an SCSS compiler, powered by the libsass library.
+With this, R developers can use variables, inheritance, and functions to
+generate dynamic style sheets.  The package uses the Sass CSS extension
+language, which is stable, powerful, and CSS compatible.")
+    (license license:expat)))
+
 (define-public r-shiny
   (package
     (name "r-shiny")