summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-01-09 23:06:16 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-01-09 23:06:16 +0100
commit349d110ae035f04dcbb2e981e72ab852a2927c4d (patch)
treedb95c676645c104b613e4c20ad529aac242fa475 /gnu/packages
parent8e864f2a3bebe4fba48c21c2024c2349d30f6f52 (diff)
downloadguix-349d110ae035f04dcbb2e981e72ab852a2927c4d.tar.gz
gnu: Add r-remacor.
* gnu/packages/cran.scm (r-remacor): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cran.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index defa68e095..32ae4140ae 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -18985,6 +18985,36 @@ can also be used to join clusters obtained from affinity propagation.  Various
 plotting functions are available for analyzing clustering results.")
     (license license:gpl2+)))
 
+(define-public r-remacor
+  (package
+    (name "r-remacor")
+    (version "0.0.11")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "remaCor" version))
+              (sha256
+               (base32
+                "0hhk1zrjz6sxg219h9ca7jya0vc8dmrvwaddajkcdns6bv3rj1km"))))
+    (properties `((upstream-name . "remaCor")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-clustergeneration
+           r-ggplot2
+           r-mvtnorm
+           r-rdpack
+           r-reshape2
+           r-runit))
+    (native-inputs (list r-knitr))
+    (home-page "https://diseaseneurogenomics.github.io/remaCor/")
+    (synopsis "Random effects meta-analysis for correlated test statistics")
+    (description
+     "Meta-analysis is widely used to summarize estimated effects sizes across
+multiple statistical tests.  Standard fixed and random effect meta-analysis
+methods assume that the estimated of the effect sizes are statistically
+independent.  Here we relax this assumption and enable meta-analysis when the
+correlation matrix between effect size estimates is known.")
+    (license license:artistic2.0)))
+
 (define-public r-rematch2
   (package
     (name "r-rematch2")