summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-02-12 21:11:02 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-02-12 21:11:02 +0200
commit42c1a83a98787ec92afff82df5c140a43cea30f0 (patch)
tree05c3d2b607f3dd86f95c1df706e5eef4924b151c /gnu/packages
parent7f237f3e6ca65dec420a6de449619c09d1806dc6 (diff)
downloadguix-42c1a83a98787ec92afff82df5c140a43cea30f0.tar.gz
gnu: coreutils-boot0: Add comment about arm* configure-flags.
* gnu/packages/commencement.scm (coreutils-boot0)[arguments]: Add a full
comment around the configure-flags used when building for arm
architectures.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/commencement.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 149d34b24c..bc06dc8120 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -1969,13 +1969,15 @@ exec " gcc "/bin/" program
     (arguments
      `(#:tests? #f
        #:implicit-inputs? #f
+       ;; The %bootstrap-glibc for aarch64 and armhf doesn't have
+       ;; $output/include/linux/prctl.h which causes some binaries
+       ;; to fail to build with coreutils-9.0+.
        ,@(if (target-arm?)
-           ;; Some binaries fail to build.
            `(#:configure-flags '(,(string-append
                                     "--enable-no-install-program="
-                                    ;; the defaults
+                                    ;; the defaults to not install.
                                     "arch,coreutils,hostname"
-                                    ;; fails on aarch64
+                                    ;; fails due to missing headers.
                                     ",timeout,sort")))
            '())
        #:guile ,%bootstrap-guile