summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2019-04-06 08:31:26 +0800
committer宋文武 <iyzsong@member.fsf.org>2019-04-10 19:00:18 +0800
commit46ecacb0c6bb27b3ddf861d1ada2fe46fea90b2f (patch)
treea3fad92af35281e42f52cbb7eeb5c4aa30d41768 /gnu/packages
parent1a4c9c2b3005a3951a568e6b9d13e5ae39dc89c2 (diff)
downloadguix-46ecacb0c6bb27b3ddf861d1ada2fe46fea90b2f.tar.gz
gnu: Add perl-filesys-notify-simple.
* gnu/packages/perl.scm (perl-filesys-notify-simple): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/perl.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 44529308cf..6dda5cdd86 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -3823,6 +3823,31 @@ functionality; it returns a list of file names that match the given pattern.
 For instance, it supports the @code{**/*.pm} form.")
     (license (package-license perl))))
 
+(define-public perl-filesys-notify-simple
+  (package
+    (name "perl-filesys-notify-simple")
+    (version "0.13")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/M/MI/MIYAGAWA/"
+                           "Filesys-Notify-Simple-" version ".tar.gz"))
+       (sha256
+        (base32
+         "18jv96k1pf8wqf4vn2ahs7dv44lc9cyqj0bja9z17qici3dx7qxd"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-test-sharedfork" ,perl-test-sharedfork)))
+    (home-page "https://metacpan.org/release/Filesys-Notify-Simple")
+    (synopsis "Simple and dumb file system watcher")
+    (description
+     "Filesys::Notify::Simple is a simple but unified interface to get
+notifications of changes to a given filesystem path.  It utilizes inotify2 on
+Linux, fsevents on OS X, kqueue on FreeBSD and FindFirstChangeNotification on
+Windows if they're installed, with a fallback to the full directory scan if
+they're not available.")
+    (license perl-license)))
+
 (define-public perl-getopt-long
   (package
     (name "perl-getopt-long")