summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-07-13 12:30:22 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-07-18 20:56:17 +0300
commit6439851b092f1d96a7195e469bac0672eb704ae7 (patch)
treeb4961327cca415378708c0b927313de770445698 /gnu/packages
parent104895fb4981d32684333789ece3f0c09ebe5d68 (diff)
downloadguix-6439851b092f1d96a7195e469bac0672eb704ae7.tar.gz
gnu: Add rust-indexmap-2.
* gnu/packages/crates-io.scm (rust-indexmap-2): New variable.
(rust-indexmap-1): Inherit from rust-indexmap-2.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm50
1 files changed, 40 insertions, 10 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 58cf2e23df..975e324f5f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -30681,23 +30681,26 @@ crate.")
 that efficiently appends and removes common indentation after every newline.")
     (license (list license:expat license:asl2.0))))
 
-(define-public rust-indexmap-1
+(define-public rust-indexmap-2
   (package
     (name "rust-indexmap")
-    (version "1.9.2")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "indexmap" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "16dkr2h5p379jcr8rnb420396yvzid2myirc2w70zcf43yffg18q"))))
+    (version "2.0.0")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "indexmap" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0pdnbvv6gnyxx2li8mks8p00fya3ynmhx3n6infpcy8a4gi7yiym"))))
     (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
        (("rust-arbitrary" ,rust-arbitrary-1)
+        ("rust-equivalent" ,rust-equivalent-1)
+        ("rust-hashbrown" ,rust-hashbrown-0.14)
         ("rust-quickcheck" ,rust-quickcheck-1)
-        ("rust-rustc-rayon" ,rust-rustc-rayon-0.4)
+        ("rust-rayon" ,rust-rayon-1)
+        ("rust-rustc-rayon" ,rust-rustc-rayon-0.5)
         ("rust-serde" ,rust-serde-1))
        #:cargo-development-inputs
        (("rust-fnv" ,rust-fnv-1)
@@ -30719,6 +30722,33 @@ removals, and it allows lookup of its elements by either hash table key
 or numerical index.  A corresponding hash set type is also provided.")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-indexmap-1
+  (package
+    (inherit rust-indexmap-2)
+    (name "rust-indexmap")
+    (version "1.9.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "indexmap" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "16dkr2h5p379jcr8rnb420396yvzid2myirc2w70zcf43yffg18q"))))
+    (arguments
+     `(#:cargo-inputs
+       (("rust-arbitrary" ,rust-arbitrary-1)
+        ("rust-quickcheck" ,rust-quickcheck-1)
+        ("rust-rustc-rayon" ,rust-rustc-rayon-0.4)
+        ("rust-serde" ,rust-serde-1))
+       #:cargo-development-inputs
+       (("rust-fnv" ,rust-fnv-1)
+        ("rust-fxhash" ,rust-fxhash-0.2)
+        ("rust-itertools" ,rust-itertools-0.10)
+        ("rust-lazy-static" ,rust-lazy-static-1)
+        ("rust-quickcheck" ,rust-quickcheck-1)
+        ("rust-rand" ,rust-rand-0.8)
+        ("rust-serde-derive" ,rust-serde-derive-1))))))
+
 (define-public rust-indexmap-1.8
   (package
     (inherit rust-indexmap-1)