summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-16 22:27:14 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-17 01:07:41 +0200
commit6cd33f855c88e63849c96d5df7ca256dd0379f4a (patch)
tree09d9edded070922e70b8dcfefc05351bf9f31c99 /gnu/packages
parent620bce25735355cf4b154a3138a0be7b4d629f96 (diff)
downloadguix-6cd33f855c88e63849c96d5df7ca256dd0379f4a.tar.gz
gnu: gnss-sdr: Update to 0.0.15.
* gnu/packages/radio.scm (gnss-sdr): Update to 0.0.15.
[arguments]: Remove 'fix-tests phase.  Tests pass regardless.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/radio.scm12
-rw-r--r--gnu/packages/security-token.scm4
2 files changed, 4 insertions, 12 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 1a9f171148..2b487d022a 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -2375,7 +2375,7 @@ of devices than RTL-SDR.")
 (define-public gnss-sdr
   (package
     (name "gnss-sdr")
-    (version "0.0.14")
+    (version "0.0.15")
     (source
      (origin
        (method git-fetch)
@@ -2384,7 +2384,7 @@ of devices than RTL-SDR.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1kjh9bnf6h9q71bnn8nrwlc80wcnkib97ylzvb102acii4p0fm08"))))
+        (base32 "1m41rnlfr1nrzbg382jfsk5x0by2ym48v3innd2rbc6phd85q223"))))
     (build-system cmake-build-system)
     (native-inputs
      `(("gfortran" ,gfortran)
@@ -2422,14 +2422,6 @@ of devices than RTL-SDR.")
                             (assoc-ref %build-inputs "googletest-source")))
        #:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'fix-tests
-           (lambda _
-             ;; Some tests fail to compile when the FILESYSTEM package is
-             ;; available, so we disable it (and the tests will use Boost
-             ;; Filesystem instead).
-             (substitute* "CMakeLists.txt"
-               (("find_package\\(FILESYSTEM COMPONENTS Final Experimental\\)")
-                ""))))
          (add-before 'check 'set-home
            (lambda _
              (setenv "HOME" "/tmp"))))))
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 1f60e25458..a24654a3e5 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -74,14 +74,14 @@
 (define-public ccid
   (package
     (name "ccid")
-    (version "1.4.34")
+    (version "1.4.36")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://ccid.apdu.fr/files/ccid-"
                                   version ".tar.bz2"))
               (sha256
                (base32
-                "02mlbpnsvy6jgwpz0jk5lh27y3cn2bsyz9xini7898m9b5dn9xz6"))))
+                "1ha9cwxkadx4rs4jj114qzh42qj02x6r8y1mvhcvijhvby4aqwrb"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags (list (string-append "--enable-usbdropdir=" %output