summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-01-31 14:23:54 +0100
committerLudovic Courtès <ludo@gnu.org>2014-01-31 14:23:54 +0100
commit70b33d81cfe4f2192a2167a82e55aabc4401c8a6 (patch)
treedc186e27224d6a5ca371c1e41808d36c384236c4 /gnu/packages
parent4919d68432c69d386300053b0de178f9efb0334f (diff)
downloadguix-70b33d81cfe4f2192a2167a82e55aabc4401c8a6.tar.gz
gnu: linux: Really build 9p/virtio modules.
* gnu/packages/linux.scm (linux-libre): Add CONFIG_NET_9P and
  CONFIG_9P_FS.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 553120ca2b..b88ecfcac0 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -173,6 +173,8 @@
                       ;; explicitly added.
                       (let ((port (open-file ".config" "a")))
                         (display (string-append "CONFIG_NET_9P_VIRTIO=m\n"
+                                                "CONFIG_NET_9P=m\n"
+                                                "CONFIG_9P_FS=m\n"
                                                 "CONFIG_VIRTIO_NET=m\n"
                                                 "CONFIG_VIRTIO_BLK=m\n"
                                                 "CONFIG_VIRTIO_BALLOON=m\n")