summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-07-13 18:44:22 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-07-18 20:56:21 +0300
commit7930b888840a8f1eddac474713a8d021ab5ed79b (patch)
treef6c8931dad54535301595e0e06ee97d86d6ba15b /gnu/packages
parentf8fa695173f6f825ead9174dff4093bb63e02db7 (diff)
downloadguix-7930b888840a8f1eddac474713a8d021ab5ed79b.tar.gz
gnu: Add rust-ref-cast-test-suite-0.0.0.
* gnu/packages/crates-io.scm (rust-ref-cast-test-suite-0.0.0): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 8c8d1937db..cabc29261c 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -51598,6 +51598,24 @@ initial value.")
         (base32
          "0av43xxjlinfqklb67rpj217cmaxfjsf8151gs0hbs4hnr5664ck"))))))
 
+(define-public rust-ref-cast-test-suite-0.0.0
+  (package
+    (name "rust-ref-cast-test-suite")
+    (version "0.0.0")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "ref-cast-test-suite" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0cx15bhs8zq99qidrhjmjhc5krlfclcaq0y5c68pq48vlds72idl"))))
+    (build-system cargo-build-system)
+    (arguments (list #:skip-build? #t))
+    (home-page "https://github.com/dtolnay/ref-cast")
+    (synopsis "Test suite of the ref-cast crate")
+    (description "Test suite of the ref-cast crate.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-refpool-0.4
   (package
     (name "rust-refpool")