summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 10:55:45 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:11 +0200
commit8332766a60580a9b9cb4bc681f763751a482d0e7 (patch)
tree7ca2df4ce10040292fb980b996e06dde1eb7a162 /gnu/packages
parent4649e211c2ef7a736290430fd1fad2e046be112d (diff)
downloadguix-8332766a60580a9b9cb4bc681f763751a482d0e7.tar.gz
gnu: Add texlive-tsemlines.
* gnu/packages/tex.scm (texlive-tsemlines): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f879250ce3..c92ab4eeb9 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5580,6 +5580,25 @@ cobordisms between circles, such as those used in TQFT and other mathematical
 diagrams.")
     (license license:lppl1.3+)))
 
+(define-public texlive-tsemlines
+  (package
+    (name "texlive-tsemlines")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "tex/latex/tsemlines/")
+             (base32
+              "1c7sjdrgqbjw6f2s3185k5rlkig643pkkahjisx16h0akbbdm4k3")))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/tsemlines")
+    (synopsis "Support for the ancient @code{\\emline} macro")
+    (description
+     "Occasional Documents appear, that use graphics generated by TeXcad from
+the EmTeX distribution.  These documents often use the @code{\\emline} macro,
+which produced lines at an arbitrary orientation.  The present package
+emulates the macro, using TikZ.")
+    (license license:public-domain)))
+
 (define-public texlive-amiri
   (package
     (name "texlive-amiri")