summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2023-02-09 21:02:05 +0100
committerAndreas Enge <andreas@enge.fr>2023-02-09 21:27:06 +0100
commit8dbc9aa05ee142fd14c708158ac9cde53bd0c858 (patch)
treebe4a19137e436f2921c0dadb07b204815cd75d03 /gnu/packages
parentbf667efe910f740282aee1ebe1891b452224d31e (diff)
downloadguix-8dbc9aa05ee142fd14c708158ac9cde53bd0c858.tar.gz
gnu: Add perl-growl-gntp.
* gnu/packages/perl.scm (perl-growl-gntp): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/perl.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 14e4934918..295f8dd141 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -35,6 +35,7 @@
 ;;; Copyright © 2022 Evgeny Pisemsky <evgeny@pisemsky.com>
 ;;; Copyright © 2022 gemmaro <gemmaro.dev@gmail.com>
 ;;; Copyright © 2023 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
+;;; Copyright © 2023 Andreas Enge <andreas@enge.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -12378,6 +12379,27 @@ regexp patterns in modules.")
 structures.")
     (license license:perl-license)))
 
+(define-public perl-growl-gntp
+  (package
+    (name "perl-growl-gntp")
+    (version "0.21")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://cpan/authors/id/M/MA/MATTN/Growl-GNTP-" version
+                    ".tar.gz"))
+              (sha256
+               (base32
+                "0gq8ypam6ifp8f3s2mf5d6sw53m7h3ki1zfahh2p41kl8a77yy98"))))
+    (build-system perl-build-system)
+    (native-inputs (list perl-module-build-tiny))
+    (propagated-inputs (list perl-crypt-cbc perl-data-uuid))
+    (home-page "https://metacpan.org/release/Growl-GNTP")
+    (synopsis "Perl implementation of the GNTP Protocol (client part)")
+    (description "Growl::GNTP is a Perl implementation of the client part
+of the  Growl Notification Transport Protocol (GNTP).")
+    (license license:perl-license)))
+
 (define-public perl-socket-msghdr
   (package
     (name "perl-socket-msghdr")