summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2015-12-29 14:37:45 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-01-26 16:11:49 +1000
commit9273ee8f448ae075b4df62b9ad793c1dcf31b7be (patch)
tree7b304a00b9724eab912af45b8e4476fa75895f07 /gnu/packages
parent120fc74b21861138e859f740fbeb02afe3f43a45 (diff)
downloadguix-9273ee8f448ae075b4df62b9ad793c1dcf31b7be.tar.gz
gnu: Add ruby-ae.
* gnu/packages/ruby.scm (ruby-ae): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ruby.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 53da3fa4f5..5cbf125ded 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3086,3 +3086,35 @@ somewhere between lower-level testing tools like @code{Test::Unit} and
 requirement specifications systems like Cucumber.")
     (home-page "http://rubyworks.github.io/qed")
     (license license:bsd-2)))
+
+(define-public ruby-ae
+  (package
+    (name "ruby-ae")
+    (version "1.8.2")
+    (source
+     (origin
+       (method url-fetch)
+       ;; Fetch from github so tests are included.
+       (uri (string-append
+             "https://github.com/rubyworks/ae/archive/"
+             version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "147jmkx54x7asy2d8m4dyrhhf4hdx4galpnhwzai030y3cdsfrrl"))))
+    (build-system ruby-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _ (zero? (system* "qed")))))))
+    (propagated-inputs
+     `(("ruby-ansi" ,ruby-ansi)))
+    (native-inputs
+     `(("ruby-qed" ,ruby-qed)))
+    (synopsis "Assertions library")
+    (description
+     "Assertive Expressive (AE) is an assertions library specifically designed
+for reuse by other test frameworks.")
+    (home-page "http://rubyworks.github.io/ae")
+    (license license:bsd-2)))