summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
author(unmatched-parenthesis <paren@disroot.org>2022-10-21 22:11:23 +0100
committerRaghav Gururajan <rg@raghavgururajan.name>2022-11-27 10:31:43 -0500
commita3e196f69ea4fd5bf9fc90dab3b6ba86e33dbb66 (patch)
tree34c1fd7fe85ef5da124c2d7d4c4ffa47e5bc7ddf /gnu/packages
parent9bb0001a0e4b262538af49f88386e4e52ea1fa00 (diff)
downloadguix-a3e196f69ea4fd5bf9fc90dab3b6ba86e33dbb66.tar.gz
gnu: Add go-git-sr-ht--sircmpwn-getopt.
* gnu/packages/golang.scm (go-git-sr-ht--sircmpwn-getopt): New variable.

Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a177b54260..779c0b6853 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9349,6 +9349,30 @@ or capture raw audio.")
 programs that use traditional command lines.")
     (license license:bsd-3)))
 
+(define-public go-git-sr-ht-sircmpwn-getopt
+  (package
+    (name "go-git-sr-ht-sircmpwn-getopt")
+    (version "1.0.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://git.sr.ht/~sircmpwn/getopt")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0f9rammnmhaz21qkmz7qf76r8jlzi323g05ps3j7gwrxlw7442a6"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:import-path "git.sr.ht/~sircmpwn/getopt"))
+    (propagated-inputs (list go-github-com-stretchr-testify))
+    (home-page "https://git.sr.ht/~sircmpwn/getopt")
+    (synopsis "POSIX getopt for Go")
+    (description
+     "This package provides a POSIX-compatible implementation of
+@code{getopt} for Go.")
+    (license license:bsd-3)))
+
 (define-public go-go-uber-org-atomic
   (package
     (name "go-go-uber-org-atomic")